Ferramentas de usuario

Ferramentas do sitio


Barra lateral

Translations of this page:

Páxina principal

Análisis e comparativas

this namespace doesn't exist: gl:analisis_y_comparativas
Documentación
this namespace doesn't exist: documentacion
Eventos Guías Ferramentas
this namespace doesn't exist: gl:herramientas
Información de interese Proxectos > Usuarios
this namespace doesn't exist: gl:user
Varios
this namespace doesn't exist: gl:varios
Wiki Privado old
this namespace doesn't exist: gl:old
admin
this namespace doesn't exist: gl:admin

mbstring extension must be loaded in order to run mPDF
gl:proyectos:opencookies

Open Cookies

MOLDES DE GALLETAS CON FERRAMENTAS LIBRES

Un dos primeiros proxectos nos que dei en pensar ao dispor dunha impresora 3D foi o de fabricar os meus propios moldes para galletas. Un obxectivo asequible, divertido e gorentoso co que podería convencer a toda a familia da utilidade do noso novo cacharro.

O primeiro paso foi procurar información na rede. En efecto, hai ducias de entradas con videos e titoriais para deseñar e imprimir os teus propios moldes. Iso si, moi poucos que se axustaran á nosa premisa de utilizar software libre. Deles, tres parécenme interesantes por diferentes razóns:

  • O primeiro é unha sinxela aplicación multiplataforma creada por Guru coa que poderedes crear formas sinxelas. Permite importar unha imaxe para usala como patrón aínda que a forma na que se crean novos nodos fai que non sexa moi operativa para o que non sexan deseños moi sinxelos.
  • O segundo é o Advanced cookie cutter genarator publicado en Instructables por Leo Marius.
  • O terceiro aparece tamén en Instructables asinado por arpuss, un argalleiro que nos ofrece outra opción interesante para fabricar moldes de galletas a partir de deseños vectoriais.

A guía que podedes ler de seguido utiliza os dous últimos, ambos extensións de Inkscape. Iso si, a receita é da nosa colleita, o mesmo que algúns trucos e indicacións que agardamos sexan de utilidade. Comezamos!

INSTALACIÓN DO SOFTWARE PRECISO

Como comentabamos no comezo deste artigo, as las aplicacións que utilizaremos tanto no proceso de deseño como no de impresión 3D son software libre. Esta era una premisa de partida coherente coa la filosofía de BricoLabs.

  • Inkscape é un editor de gráficos vectoriais multiplataforma. Utilizarémolo para deseñar os nosos moldes. Se non o tes instalado faino en primeiro lugar.
  • Descarga do seguinte enlace Path to cookies, o script desenvolvido por Leo Marius para converter un vector de Inkscape nun arquivo archivo de OpenSCAD. Para instalalo só tes que copiar o contido do arquivo .zip directamente na carpeta “Extensions” de Inkscape. En Windows debería estar en C:\Program Files (x86)\Inkscape\share\extensions. Algo así como /usr/share/inkscape/extensions en Linux.
  • OpenSCAD é un software para a creación de obxectos sólidos CAD en 3D mediante programación. Con el transformaremos os nosos deseños en arquivos .stl.
  • Instala na carpeta Extensions de Inkscape o OpenSCAD cookie cutter tal e como describimos no punto anterior. Unha vez instalada, esta extensión permitiranos gardar un deseño vectorial en formato OpenSCAD e configurar unha serie de parámetros para transformalo nun cortador de galletas. Máis adiante veremos como utilizala.
  • Freecad é un software de modelado 3D paramétrico co que poderemos transformar os nosos arquivos .stl en caso necesario. Veremos máis cando e como nos pode ser de utilidade.
  • Para o proceso de impresión 3D no meu caso utilizo o laminador Slic3r e Pronterface.

MÉTODO 1: USANDO PATH TO COOKIES

DESEÑO DA GALLETA EN INKSCAPE

Aqueles que, como é o meu caso, non dominedes moito este programa, aconséllovos consultar algún titorial básico. Podedes atopar moita información na rede. A verdade é que eu non seguín ningún en concreto, máis ben fun peteirando aco e aló, así que non vos aconsellarei ningún máis aló do que se inclúe na páxina oficial.

Para ir describindo o proceso deseñaremos e imprimiremos un molde a partires do debuxo dun neno, en concreto do “coello de orellas pequenas” que debuxou a miña sobriña. Estes son os pasos a seguir:

  • Abrimos un documento novo de Inkscape e configuramos as súas dimensións (Archivo>Tamaño del documento). Deste xeito teremos unha referencia do tamaño do molde para que non sexa demasiado grande. 10×10 cm pode ser abondo.
  • A continuación importamos o debuxo escaneado previamente, axustámolo ao tamaño axeitado e bloqueamos a capa para non modificalo por erro.

01_inkscape_tamac3b1o-documento1.jpg

  • Creamos unha nova capa por riba e coa ferramenta Bezier imos calcando o contorno do debuxo. É útil modificar a cor do trazo e o seu grosor para podelo visualizar ben.

02_inkscape_bezier.jpg

  • Comproba ao final do proceso de deseño que tes un traxecto para evitar erros. Se non é así, selecciónao e transfórmao no menú Objeto>Objeto a trayecto.
  • Deixa os detalles interiores para máis adiate, logo veremos a mellor maneira de trasladalos ao teu molde.
  • O obxectivo do deseño é converterse nunha galleta. Ten isto en conta á hora de deseñalo e simplifica a forma sen que perda a súa identeidade.

Unha vez terminado o debuxo, é o momento de utilizar o script Path to Cookies!

PATH TO COOKIES

Selecciona o obxecto que desexes importar e fai clic no menú Extensiones> Generar desde trayecto>Path to cookies.O menú Path to Cookies debería abrirse.

03_path_menu1.jpg

Vexamos os diferenres parámetros que podemos configurar no mesmo:

Path to cookies (pestana principal ):

  • Output file: en primero lugar debemos asegurarnos que a ruta de acceso para gardar o documento é correcta e modificala en caso preciso, asegurándonos que ao final da mesma indicamos un nome de arquivo coa extensión .scad. Esta verificación é moi importante porque cando abramos este menú de novo aparecerá a última ruta e nome de arquivo gardado. Se non o cambiamos, reescribirao sen preguntarnos novamente.
  • Height(mm): indicaremos a altura total en mm do noso molde. No noso caso 10 mm.
  • Thickness(mm): espesor da parede do molde. É aconsellable que sexa un múltiplo do calibre do nozzle da túa impresora 3D para obter mellores resultados. Nós poremos 0.80 pois o noso é de 0.40 mm. 1.2 mm tamén é unha boa opción para a maior parte das impresoras (0,3 e 0,4 mm de boquillas). A parede non debe ser moi grosa para que o corte da masa sexa limpo.

04_path_menu2.jpg

Advanded settings (pestana de configuración avanzada):

  • Flange Type: define o tipo de pestana de agarre arredor do molde. Para o noso exemplo escolleremos o 1, a pestaña clásica. Como veremos máis adiante, pode ser interesante facer un molde sen pestana para detalles interiores.
    • 0: sen pestana.
    • 1: pestana clásica
    • 2: bisel

04_pestac3b1as.jpg

  • Flange height: define a altura da pestana. Neste caso indicamos 1.2 mm
  • Flange width: define o ancho da mesma, 3mm pode ser unha boa opción.

No caso 2 (bisel) a altura e o ancho determinarán ol ángulo do bisel. Se os dous teñen o mesmo valor o ángulo será de 45º.

  • Solid: producirá obxectos sólidos. Pode ser moi útil para facer membretes ou para detalles interiores como veremos máis adiante.
  • Smoothing: definirá a suavidade coa que se convertirá a forma vectorial. Canto máis baixo sexa máis preciso será pero máis tardará logo en renderizar. Utilizaremos 0.2, o valor por defecto.

05_path_menu3.jpg

Grid Settings (axuste da grella de soporte)

A grella de soporte será últil cando vaiamos a incluír no noso molde elementos interiores para marcar ou facer baleirados interiores. Non caso de non precisar estes elementos é aconsellable non utilizala pois será máis doado desmlodar as galletas.

  • Enabled grid: activa ou desactiva esta opción.
  • Grid barsThickness: define o grosor das barras da grella.
  • Grid barsSpacing: define o espazo entre cada una das barras da grella.
  • Grid rotation adjustment: permite xirar a grella no eixo Z.

Unha vez configuradas todas estas opcións exportamos o molde e abrímolo con OpenSCAD. Se é grande e require moitos cálculos pode tardar en abrirse. Unha vez en pantalla facemos clic no botón Render (ou prememos F6) para visualizalo. Agora só queda exportalo en formato STL. Xa temos o noso molde listo para imprimir.

06_openscad.jpg

No arquivo .scad podemos modificar todos os parámetros vistos anteriormente e ademais algúns outros que só poderemos configurar nel. Son os seguintes:

  • gridThickness: cambiar o grosor da grella. Por defecto será o mesmo que o da asa.
  • shiftX: Valor para facer algúns pequenos axustes na posición de agarre do eixe X.
  • Shifty: Valor para facer algúns pequenos axustes na posición de agarre do eixe Y.
  • maxGridX y maxGridY: Tamaño máximo da rede. Se se quere construír un molde maior de 300 mm haberá que adaptar este parámetro. Tamén pode axustarse para reducir o tempo de cálculo.

Detalles interiores: queremos que corten ou que marquen?

Ata aquí as instruccións para crear un molde que corte a masa sen ningún tipo de elemento interior. Pero en ocasións quereremos incorporar aos nosos deseños baleirados ou impresioóns sobre a masa. Vexamos como facelo seguindo uns exemplos.

CASO 1: Imaxinemos que queremos crear un molde para unha galleta coa forma de donut ou rosquilla, unha circunferencia exterior con outra recortada no interior.

  • Paso 1: Debuxamos as dúas circunferencias concéntricas en Inkscape.
  • Paso 2: Utilizamos a ferramenta Trayecto>Diferencia para restar o círculo interior ao exterior. Este é o paso clave.

07_donut_recorte.jpg08_donut_recorte2.jpg

  • Paso 3: Seleccionamos a forma resultante e utilizamos Path to cookies activando a grella. Agora só resta exportar e imprimir.

09_donut_openscad.jpg

CASO 2: Nesta ocasión imos crear un elemento que marque no interior da nosa galleta para debujar sobre ela una determinada forma. Por exemplo, o ollo e as manchas no noso “Coello de orellas pequenas”. Para elo, sigamos estes pasos:

  • Creamos o molde exterior seguindoas instruccións deste titorial asegurándonos que incluímos a grella de soporte.
  • Abrimos o debuxo en Inkscape e trazamos coa ferramenta Bezier a forma da mancha. Non noso caso trazaremos unha liña cun grosor de 0.4 mm. Logo transformamos a liña a traxeto e exportamos con Path to cookies cunha parede de 0,3 mm, altura de 8mm (para que quede máis alta que o corte exterior), sen asa e marcando a opción sólido. Ás veces esta opción non se exporta correctamente; nese caso deberemos activala no arquivo.scad cambiando full=false por full=true (liña 15). Podedes xogar o grosor da líña e o ancho da parede para obter o ancho desexado.

10_interior-coello_borde.jpg11_interior-coello_borde-a-trayecto.jpg12_interior-coello_openscad.jpg

  • Abrimos Freecad e importamos os arquivos stl de exterior e da forma interior e convertémolos a sólido. Tedes un video titorial xenial de Obijuan sobre este proceso.
  • Emplazamos a forma interior no seu lugar e unimos ambas formas.

13_interior-coello_freecad.jpg

  • Repetimos este proceso as veces necesarias para completar o noso molde.
  • En casos como o do ollo do noso coello, pode ser máis fácil utilizar as ferramentas propias de Freecad directamente. Neste caso agregamos un cubo para situar correctamente un cilindro para o ollo.

14_interior-coello_freecad2.jpg

CASO 3: Para marcar interiormente la galleta, ás veces pode ser máis interesante crear un tampón interior. Nese caso:

  • Realizamos o molde exterior segundo o descrito sen engadir grella de soporte.
  • Creamos a forma interior seguindo as instruccións do caso 2
  • En Freecad importamos ambas formas, convertémolas a sólido (como se describe no caso 2) pero en vez de unilas ao molde exterior colocarémolas sobre unha plataforma que poida apoiarse sobre o molde para marcar as galletas.
  • Podemos crear en Inkscape unha forma similar á nuestra galleta un pouco máis pequena, de xeito que encaixe nela. Poderiamos utilizar a opción sólido para crear a superficie de apoio.

15_bricolabs.jpg

Logo dun tempo utilizando o primeiro método para deseñar moldes de galletas dei cun artigo en Instructables que facilitaba o proceso sobre todo para aqueles moldes que conteñen diferentes elementos interiores que desexamos que marquen a galleta. Trátase do OpenSCAD cookie cutter. Podedes instalalo seguindo as instruccións descritas anteriormente.

Vexamos como funciona a través dun exemplo. Imos deseñar o molde dunha galleta para o logotipo da Obijuan Academy. Nesta wiki, sobradamente coñecida entre os seguidores das tecnoloxías abertas, podedes atopar unha chea de videotitoriais compartidos por Juan González “Obijuan” ao que toda a comunidade debemos agradecer a súa xenerosidade e impagable contribución á difusión do software e hardware libre.

DESEÑO DA GALLETA EN INKSCAPE

Podemos seguir os pasos explicados no Método 1 para obter o noso debuxo a partir dunha imaxe ou podemos importar un arquivo vectorial. Neste segundo caso, déixovos uns consellos que poden servos de utilidade:

  • Recordade converter a traxecto (Trayecto>Objeto a trayecto) e desagrupar (Objeto>Desagrupar) para poder manipular posteriormente.
  • Eliminade todo o recheo: facede clic no X e na paleta de cores situada na esquina inferior dereita da pantalla de Inkscape.
  • Transformade todos os contornos en negro: Maiúsculas + clic no recadro negro na paleta de cores.
  • Eliminade as liñas duplicadas e os detalles que creades non funcionarán ben nunha galleta.
  • Axustade o tamaño do deseño seguindo as indicacións descritas no Método 1.

Unha vez rematado o deseño, modificaremos as cores das liñas seguindo este criterio:

  • Utilizaremos o contorno vermello nas paredes exteriores. Debe ser un polígono único.
  • Utilizaremos o contorno verde en calquera parede interior (furados). Tede en conta que se os cortes interiores son moi pequenos ou angulosos non se desmoldará ben.
  • Ulilizaremos o negro para aqueles detalles que queiramos que marquen sen cortar a galleta. Imos crear unha parede que non chega ata o fondo, polo que marca a galleta e non a corta. É importante axustar ben esta altura, como veremos máis adiante.
  • Se hai detalles ou paredes internas non conectadas ás paredes exteriores agregaremos polígonos con recheo para unilos ás mesmas. Recordade, o resto das formas deben ser traxectos sen recheo.

Para rematar este proceso, gardaremos o noso deseño. Neste caso, a ruta é Archivo>Guardar como>OpenSCAD cookie cutter file. Asegúrate de que se garda con extensión .scad; xa case temos o noso molde!

Abramos o novo arquivo e vexamos os diferenres parámetros que podemos configurar:

  • wallHeight ou altura da parede exterior. Por defecto 12 mm pero no noso caso 10 mm será abondo.
  • wallFlareWidth ou ancho da asa de agarre. Por defecto 3mm; cambiamos a 5 mm para un agarre mellor.
  • WallFlareThickness ou altura da asa de agarre. Por defecto 1.5 mm. Mantemos este valor.
  • minWallWidth ou ancho mínimo da parede exterior. Por defecto 1 mm. Este é o parámetro no que configuraremos o grosor do cortador. Deberemos buscar un valor para que sexa fino abondo para cortar e suficientemente consistente para non crebar facilmente. Ademais, é convinte atopar un valor proporcional ao diámetro do nozzle. No noso caso poremos 1.2 mm porque temos un nozzle de 0.4 mm.
  • maxWallWidth ou ancho máximo da parede exterior. Por defecto 3 mm. Mantemos este valor.
  • insideWallFlareWidth ou ancho da asa de agarre da pared interior. Valor por defecto 2mm. Mantémolo.
  • insideWallFlareThickness ou altura da asa de agarre da parede interior. Valor por defecto 1.5 mm. Mantémolo.
  • MinInsideWallWidth ou ancho mínimo da parede interior. Por defecto 1 mm. Vale o mesmo razoamento que en minWallWidth. Cambiámolo a 1.2 mm.
  • maxInsideWallWidth ou ancho máximo da parede interior. Por defecto 3 mm. Mantemos este valor.
  • featureHeight ou altura das paredes de detalle. Valor por defecto 8mm. Este valor é moi importante e dependerá do grosor das galletas que queiramos formear e da profundidade da marca que queiramos facerlle. Obviamente, debe ser menor que wallHeight e tede en conta que se a diferenza é pequena e esta parede entra demasiado na masa teredes dificultades para desmoldalas. O ideal é que marquen a masa o mínimo para que se note. O noso valor é de 5 mm.;
  • minFeatureThickness ou ancho mínimo das paredes de detalle. Vai determinar o grosor das marcas interiores. Por defecto 0.8 mm. No noso caso igualámolo ao grosor das paredes exteriores, 1.2 mm.
  • maxFeatureThickness ou ancho máximo das paredes de detalle. Por defecto 3 mm. Mantemos este valor.
  • connectorThickness ou altura das superficies de conexión dos detalles interiores. Valor por defecto 1 mm. No nos caso mantémolo aínda que poderíamolo ter igualado ao WallFlareThickness.
  • size ou tamaño do molde. Axustando este parámetro cambiaremos o tamaño do molde sen cambiar o grosor das paredes o que é moi útil.

Poderemos ir visualizando todos os cambios no molde pulsando F5 ou o icono de Previsualizar. Unha vez finalizados os axustes, prememos F6 ou Render para xenerar a malla. Unha vez rematado, prememos o botón STL para exportar un arquivo STL. O molde está listo para ser impreso.

Recordade que como comentabamos máis arriba, se precisamos que as marcas interiores sexan moi complexas, pode ser máis doado crear un tampón interior para obter ditas formas. Para elo precisaremos un programa de modelado 3D como Freedad para agregar as diferentes formas. Poño como exemplo este molde creado con este segundo método seguindo estes pasos:

  1. Creamos o cortador exterior.
  2. Creamos o sólido interior (connector) recheando a silueta exterior escalada ao 95% cunha altura de 1,5 mm.
  3. Creamos os sólidos interiores con este mesmo método cunha altura de 5 mm.
  4. Importamos en Freecad, convertemos en solidos e agregamos a base e as formas do paso 3.

Hai un método alternativo para este terceiro paso: importar directamente o SVG dende Freecad e extruír as formas. Tedes un par de excelentes videotitoriais (este e este outro) sobre este proceso na Obijuan Academy

MATERIAL DE IMPRESIÓN

  • Para imprimir usaremos PLA, un termoplástico biodegradable procedente de recursos renovables como o millo, raíces de tapioca, féculas e almidóns varios e da cana de azúcar. Grazas á súa consistencia máis fluída a temperatura de extrusión (180-220ºC), é ideal para imprimir pezas con paredes finas. O PLA non é tóxico e pode estar en contacto cos los alimentos en frío.
  • Limpar os moldes con auga morna e xabrón despois de itilizalos. Nunca no lavalouzas.
  • Para unha maior seguridade alimentaria é convinte que a boquilla da impresora sexa de acero inoxidable (e non de latón polo seu contido en plomo).

RECEITA PARA MASA:

  • 125 gr. de manteiga
  • 175 gr. de fariña
  • 50 gr. de azucre glass
  • 1 cullerada de leite

RECEITA PARA MASA CON CHOCOLATE

  • 125 gr. de manteiga
  • 160 gr de fariña
  • 50 gr. de cacao en polvo.
  • 50 gr.de azucre glass
  • 3 culleradas de leite

PREPARACIÓN:

Peneira os 175 gramos de farina nun cunco, engade o azucre, o cacao no caso da masa con chocolate, e remove. Engade os 125 gramos de manteiga en anacos, traballa a manteiga e a fariña xuntas ata que a mistura parezan migas. Engade unha cullerada de leite e mistura coas mans ata formar unha bóla de masa.

Deixa arrefriar a masa na neveira unhas horas envolta nun filme transparente para que sexa máis fácil de traballar. Prepara una superficie lisa e empóaa de fariña. Estira a masa cun rolete enfariñado ata obtener o grosor desexado e emplea o molde para cortarla. Coloca as galletas na bandexa sobre un papel de forno e enforna a 180º. É importante ter prequentado o forno a esa temperatura.

A continuación déixovos algunhas imaxes do proceso. Bo proveito!

25_galletas.jpgASCII���...ASCII���...

gl/proyectos/opencookies.txt · Última modificación: 2018/11/16 19:31 por Xosé Pérez