Herramientas de usuario

Herramientas del sitio


Barra lateral

Traducciones de esta página:

Página principal

Análisis y comparativas

Documentación
esta sección no existe: documentacion
Eventos Guías Herramientas Información de interés Proyectos > Usuarios Varios Wiki Privado

No hay páginas en esta sección.


old admin

No hay páginas en esta sección.


proyectos:opencookies

OPEN COOKIES

MOLDES DE GALLETAS CON HERRAMIENTAS LIBRES

Uno de los primeros proyectos en los que pensé al disponer de impresora 3D es el de fabricar moldes para galletas. Un objetivo asequible, divertido y suculento con el que podría convencer a toda la familia de la utilidad de nuestro nuevo cacharro.

El primer paso fue buscar información en internet. En efecto, hay decenas de entradas con videos y tutoriales para fabricar e imprimir tus propios moldes. Eso si, pocos que se ajustaran a nuestra premisa de utilizar para ello software libre. De ellos, tres me parecen interesantes por diferentes razones:

  • El primero es una sencilla aplicación multiplataforma creada por Guru con la que podéis crear formas sencillas. Permite importar una imagen para usarla como patrón aunque la forma en que se crean nuevos nodos hace que no sea muy operativa para aquello que no sean diseños muy sencillos.
  • El segundo es el Advanced cookie cutter genarator publicado en Instructables por Leo Marius.
  • El tercero también aparece en Instructables firmado por arpruss, un maker que nos ofrece otra interesante opción para fabricar moldes de galletas a partir de diseños vectoriales.

La guía que podéis leer a continuación está basada fundamentalmente en el segundo y utiliza el complemento de Inkscape “Path to cookies” . Eso si, la receta es de nuestra cosecha, lo mismo que algunos trucos e indicaciones que esperamos os sean de utilidad.¡Comenzamos!

INSTALACIÓN DEL SOFTWARE NECESARIO

Como comentamos al principio de este artículo, las aplicaciones que utilizaremos tanto en el proceso de diseño como en el de impresión 3D son software libre. Esta era una premisa de partida coherente con la filosofía de BricoLabs-

  • Inkscape es un editor de gráficos vectoriales para Windows, Mac OS X y Linux. Lo utilizaremos para diseñar nuestros moldes. Si no lo tienes instalado puedes hazlo en primer lugar.
  • Descarga del siguiente enlace Path to cookies, el script desarrollado por Leo Marius para convertir un vector de Inkscape en un archivo de OpenSCAD. Para instalarlo sólo tienes que copiar el contenido del .zip directamente en la carpeta “Extensions” de Inkscape. En Windows debería estar en C:\Program Files (x86)\Inkscape\share\extensions. Algo así como /usr/share/inkscape/extensions en Linux.
  • OpenSCAD es un software para la creación de objetos sólidos CAD en 3D mediante programación. Con el transformaremos nuestros diseños en archivos .stl.
  • Inatala en la carpeta “Extensions” de Inkscape el OpenSCAD cookie cutter tal y como hemos descrito anteriormente. Una vez instalada, esta extensión nos permitirá guardar un diseño vectorial en formato OpenSCAD y configurar una serie de parámetros para transformarlo en un cortador de galletas. Más adelante veremos como utilizarla.
  • Freecad es un software de modelado 3D paramétrico con el que podremos transformar nuestros archivos .stl en caso necesario. Veremos más adelante cuando nos puede ser útil.
  • Para el proceso de impresión 3D en mi caso utilizo el laminador Slic3r y Pronterface.

MÉTODO 1: USANDO PATH TO COOKIES

DISEÑO DE LA GALLETA EN INKSCAPE

Utilizaremos Inkscape para diseñar nuestra galleta. Para aquellos que, como en mi caso, no dominéis este programa os aconsejo algún tutorial básico. Podéis encontrar mucha información en la red. La verdad es que yo no he seguido ninguno, más bien he ido picando aquí y allí así que no os aconsejaré ninguno más que el que incluye la página oficial.

Para ir describiendo los diferentes pasos del proceso nos centraremos en diseñar e imprimir un molde a partir del dibujo de un niño, concretamente a partir del “conejo de orejas pequeñas” que ha dibujado mi sobrina. Estos son los pasos a seguir:

  • Abrimos un documento nuevo de Inkscape y configuramos sus dimensiones (Archivo>Tamaño del documento). De esta manera tendremos una referencia del tamaño del molde para que no sea demasiado grande. 10×10 cm puede ser suficiente.
  • A continuación importamos el dibujo escaneado previamente, lo ajustamos al tamaño deseado y bloqueamos la capa para no modificarlo por error.

01_inkscape_tamac3b1o-documento1.jpg

  • Creamos una nueva capa por encima y con la herramienta Bezier vamos calcando el contorno del dibujo. Es útil modificar el color del trazo y su grosor para que lo podamos ver bien.

02_inkscape_bezier.jpg

  • Comprueba al final del proceso de diseño que este es un trayecto para evitar errores. Si no es así, seleccionalo y ve al menú Objeto>Objeto a trayecto.
  • Deja los detalles interiores para más adelante, luego veremos la mejor manera de trasladarlos a tu molde.
  • El objetivo del diseño es convertirse en una galleta. Ten esto en cuenta a la hora de hacerlo y simplifica la forma sin que pierda su identidad.

Una vez terminado el dibujo, es el momento de utilizar el script Path to Cookies!

PATH TO COOKIES

Selecciona el objeto que deseas exportar y haz clic en el menú Extensiones> Generar desde trayecto>Path to cookies. El menú Path to Cookies debería abrirse. 03_path_menu1.jpg

Veamos los diferentes parámetros que podemos configurar en el mismo:

Path to cookies (pestaña principal ):

  • Output file: en primer lugar debemos asegurarnos que la ruta de acceso para guardar el documento es la correcta y cambiarla en caso necesario asegurándonos que al final de la misma indicamos el nombre del archivo con la extensión .scad. Esta verificación es muy importante ya que cuando abramos este menú de nuevo aparecerá la última ruta y nombre de archivo guardado. Si no lo cambiamos, lo sobrescribirá sin preguntarnos nuevamente.
  • Height(mm): indicaremos la altura total en mm de nuestro molde. En nuestro caso 10 mm
  • Thickness(mm): espesor de la pared del molde. Es aconsejable que sea un múltiplo del calibre del nozzle de tu impresora 3D para obtener mejores resultados. Pondremos 0.80 pues el nuestro es de 0.40 mm. 1.2 mm es también buena opción para la mayoría de las impresoras (0,3 y 0,4 mm de boquillas).

04_path_menu2.jpg

Advanded settings (pestaña de configuración avanzada):

  • Flange Type: define el tipo de pestaña de agarre alrededor del molde. En nuestro ejemplo escogeremos el 1, la pestaña clásica. Como veremos más adelante, puedes ser interesante hacer un molde sin pestaña para detalles interiores.
    • 0: sin pestaña.
    • 1: pestaña clásica
    • 2: bisel

04_pestac3b1as.jpg

  • Flange height: define la altura de la pestaña. En este caso indicamos 1.2 mm
  • Flange width: define el ancho de la misma, 3mm puede ser una buena opción.

(En el caso 2 (bisel) la altura y el ancho determinarán el ángulo del bisel. Si los dos tienen el mismo valor el ángulo será de 45º)

  • Solid: producirá objetos sólidos. Puede ser muy útil para hacer membretes objetos o para detalles interiores como veremos más adelante.
  • Smoothing: Se definirá la suavidad con la que se convertirá la forma vectorial. Cuanto más bajo sea el valor más preciso será pero más tardará en renderizar. Utilizaremos 0.2 , el valor por defecto.

05_path_menu3.jpg

Grid Settings (ajuste de rejilla de soporte)

La rejilla de soporte es útil cuando queramos incluir en nuestro molde elementos interiores para marcar o hacer vaciados interiores. En caso de no necesitar estos elementos es aconsejable no usarla pues será más fácil desmoldar las galletas.

  • Enabled grid: activa o desactiva esta opción.
  • Grid barsThickness: define el grosor de las barras de la rejilla.
  • Grid barsSpacing: define el espacio entre cada una de las barras de la rejilla.
  • Grid rotation adjustment: permite girar la rejilla en el eje Z.

Una vez configuradas todas estas opciones exportamos nuestro molde y lo abrimos con OpenSCAD. Si es grande y requiere de muchos cálculos puede tardar en abrirse. Una vez en pantalla y hacemos clic en el botón Render (o presionamos F6) para visualizar nuestro molde. Ahora solo nos queda exportarlo en formato STL. Ya tenemos nuestro molde listo para imprimir.

06_openscad.jpg

En el archivo scad podemos modificar todos los parámetros vistos anteriormente además de algunos otros que solamente podremos configurar en el. Son los siguientes:

  • gridThickness: cambiar el grosor de la rejilla. Por defecto su grosor será en mismo que el del asa.
  • shiftX: Valor para hacer algunos pequeños ajustes en la posición de agarre en el eje X.
  • Shifty: Valor para hacer algunos pequeños ajustes en la posición de agarre en el eje Y.
  • maxGridX y maxGridY: El tamaño máximo de la red. Si se construye un molde mayor de 300 mm tendrá que adaptar este parámetro. También puede ajustarse para reducir el tiempo de cálculo.

Los detalles interiores: ¿Queremos que corten o que marquen?

Hasta aquí las instrucciones para crear un molde que corte la masa sin ningún tipo de elemento interior. Pero en ocasiones querremos incorporar a nuestros diseños vaciados o impresiones sobre la masa. Veamos cómo hacerlo siguiendo unos ejemplos.

CASO 1: Imaginemos que queremos crear un molde para una galleta con la forma de donut o rosquilla, una circunferencia exterior con otra recortada en el interior.

  • Paso 1: Dibujamos las dos circunferencias concéntricas en Inkscape.
  • Paso 2: Utilizamos la herramienta Trayecto>Diferencia para restar el círculo interior al exterior. Este es el paso clave.

07_donut_recorte.jpg08_donut_recorte2.jpg

  • Paso 3: Seleccionamos la forma resultante y utilizamos Path to cookies activando la rejilla. Ahora solo resta exportar e imprimir.

09_donut_openscad.jpgCASO 2: En esta ocasión vamos a crear un elemento que marque el interior de nuestra galleta para dibujar sobre ella una determinada forma. Por ejemplo, el ojo y las manchas de nuestro “Conejo de orejas pequeñas”. Para ello, vamos a seguir estos pasos:

  • Creamos el molde exterior siguiendo las instrucciones del tutorial asegurándonos que incluímos la rejilla de soporte.
  • Vamos a nuestro dibujo en Inkscape y trazamos con la herramienta Bezier la forma de la mancha. En nuestro caso vamos a trazar con una línea de 0.4 mm. Luego transformamos la línea a trayecto y exportamos con Path to cookies con pared de 0,3 mm, altura de 8mm (para que quede más alta que el corte exterior),sin asa y marcando la opción sólido. A veces esta opción no se exporta correctamente; en ese caso deberemos activarla en el archivo.scad cambianado full=false por full=true (linea 15). Podéis jugar con el grosor de la línea y del ancho de la pared para obtener el ancho deseado.

10_interior-coello_borde.jpg11_interior-coello_borde-a-trayecto.jpg12_interior-coello_openscad.jpg

  • Abrimos Freecad e importamos los archivos stl del exterior y de la forma interior y los convertimos a sólido. Teneis un video tutorial genial de Obijuan sobre este proceso.
  • Emplazamos la forma interior en su lugar y unimos ambas formas.

13_interior-coello_freecad.jpg

  • Repetimos este proceso las veces necesarias para completar nuestro molde.
  • En casos como el del ojo de nuestro conejo puede ser más fácil utilizar Freecad directamente. En este caso hemos agregado un cubo para situar correctamente el cilindro.

14_interior-coello_freecad2.jpg

CASO 3: Para marcar interiormente la galleta, a veces puede ser máis interesante crear un tampón interior. En ese caso:

  • Realizamos el molde exterior según se ha descrito sin añadirle rejilla de soporte.
  • Creamos la forma interior siguiendo las instrucciones del caso 2
  • En Freecad importamos ambas formas, las convertimos a sólido (como se describe en el caso 2) pero en vez de unirlas al molde exterior las colocamos sobre una plataforma que pueda apoyar sobre el molde para marcar las galletas.
  • Podemos crear en Inkscape una forma similar a nuestra galleta un poco más pequeña, de manera que encaje en ella, podremos utilizar la opción sólido para crear esa superficie de apoyo.

15_bricolabs.jpg

Despues de un tiempo utilizando el primer método para diseñar moldes de galletas encontré en Instructables un artículo que facilitaba el proceso sobre todo para aquellos moldes que contienen diferentes elementos interiores que desamos que marquen nuestra galleta. Se trata del OpenSCAD cookie cutter que podeis instalar siguiendo las instrucciones descritas anteriormente.

Veamos como funciona a través de un ejemplo. Vamos a diseñar el molde de galletas para el logotipo de la Obijuan Academy. En esta wiki, sobradamente conocida ente los seguidores de las tecnologías abiertas, podreis encontrar videotutoriales compartidos por Juan González “Obijuan” al que toda la comunidad debemos agradecer su generosidad y su impagable contribución a la difusión del software y hardware libre.

DISEÑO DE LA GALLETA EN INKSCAPE

Podemos seguir los pasos explicados en el Método 1 para obtener nuestro dibujo a partir de una imagen o podemos importar un archivo vectorial. Para el segundo caso os dejo unos consejos que pueden ser de utilidad:

  • Recordad convertir a trayecto (Trayecto>Objeto a trayecto) y desagrupar (Objeto>Desagrupar) para poder manipular posteriormente.
  • Eliminad todo el relleno: haced clic en X en la paleta de colores en la esquina inferior izquierda de la pantalla de Inkscape.
  • Trasformad todos los contornos en negro: Mayúscula + clic en el cuadrado negro en la paleta de colores.
  • Eliminad las líneas duplicadas y los detalles que no funcionarán bien en una galleta.
  • Ajustad el tamaño del diseño siguiendo las indicaciones del Método 1

Una vez el diseño esté terminado vamos a modificar los colores de las lineas siguiendo este criterio:

  • Utilizaremos el contorno rojo en las paredes exteriores. Debe ser un único polígono.
  • Utilizaremos el contorno verde en cualquier pared interior (agujeros). Tened en cuenta que si los cortes interiores son muy pequeños o angulosos no se desmoldarán bien.
  • Utilizaremos el contorno negro para aquellos detalles que queramos que se marquen sin cortar la galleta. Generaremos una pared que no llega hasta el fondo, por lo que marca la galleta pero no la corta. Es importante ajustar bien esta altura, como veremos más adelante.
  • Si hay detalles o paredes internas no conectadas a la pared exterior, agregue polígonos rellenos conectando los detalles a la misma. El resto de las formas deben ir sin relleno.

Terminado este proceso guardemos nuestro diseño. En este caso Archivo>Guardar como>OpenSCAD cookie cutter file. Asegúrate de que se guarda con una extensión .scad; ya casi tenemos nuestro molde!

Abramos el nuevo archivo y veamos los diferentes parámetros que podemos configurar:

  • wallHeight o altura de la pared exterior. Por defecto 12 mm. pero en nuestro caso 10 mm. es suficiente.
  • wallFlareWidth o ancho del asa de agarre. Por defecto 3mm; cambiamos a 5 mm para un mejor agarre.
  • WallFlareThickness o altura del asa de agarre. Por defecto 1.5 mm. Mantenemos este valor.
  • minWallWidth o ancho mínimo de pared exterior. Por defecto 1 mm. Este es el parámetro en el que configuraremos el grosor del cortador. Deberemos buscar un valor para que sea lo suficientemente fino para cortar y lo suficientemente consistente para no romper facilmente. Además, es conveniente encontrar un valor proporcional al diámetro de nustro nozzle. En nuestro caso pondremos 1.2 mm ya que nuestro nozzle es de 0.4 mm.
  • maxWallWidth o ancho máximo de pared exterior. Por defecto 3 mm. Mantenemos este valor.
  • insideWallFlareWidth o ancho del asa de agarre de la pared interior. Valor por defecto 2mm. Lo mantendermos,
  • insideWallFlareThickness o altura del asa de agarre de la pared interior. Valor por defecto 1.5 mm. Lo mantenemos.
  • MinInsideWallWidth o ancho mínimo de pared interior. Por defecto 1 mm. Vale el mismo razonamiento que en minWallWidth. Lo cambiamos a 1.2 mm.
  • maxInsideWallWidth o ancho máximo de pared interior. Por defecto 3 mm. Mantenemos este valor.
  • featureHeight o altura de las paredes de detalle. Valor por defecto 8mm. Este valor es importante y dependerá del grosor de las galletas que vayamos a hornear y de la profundidad de la marca que queramos hacer. Obviamente, debe ser menor que wallHeight y tened en cuenta que si la diferencia es pequeña y esta pared se clava demasiado en la masa tendreis dificultades para desmoldarlas. Lo ideal es que marquen la masa lo mínimo para que se note. Nuestro valor es de 5 mm.;
  • minFeatureThickness o ancho mínimo de las paredes de detalle. Es el que va a determinar el grosor de las marcas interiores. Por defecto 0.8 mm. En nuestro caso lo hemos igualado al grosor de las paredes exteriores, 1.2 mm.
  • maxFeatureThickness o ancho máximo de las paredes de detalle. Por defecto 3 mm. Mantenemos este valor.
  • connectorThickness o altura de las superficies de conexión de los detalles interiores. Valor por defecto 1mm. En nuestro caso lo hemos mantenido aunque podríamos igualarlo al WallFlareThickness.
  • size o tamaño del molde. Ajustando este parámetro se cambiará el tamaño del molde sin cambiar el grosor de las paredes, lo cual es muy útil.

Podremos ir visualizando todos los cambios en nuestro molde pulsando F5 o el icono de Previsualizar. Una vez finalizados los ajustes, presionamos F6 o Render para generar la malla. Cuando haya terminado, presionamos el botón STL para exportar un archivo STL. El molde está listo para ser impreso.

Recordad que como comentábamos más arriba, si necesitamos que las marcas interiores sean muy complejas, puede ser más facil crear un tampón interior para marcar dichas formas. Para ello necesitaremos un programa de modelado 3D como Freecad para agregar las diferentes formas. Pongo como ejemplo este molde creado con ente segundo método siguiendo estos pasos:

  1. Creamos el cortador exterior.
  2. Creamos el sólido interior (connector) rellenando la silueta exterior escalada ao 95% con una altura de 1.5 mm. Esto nos servirá de base del tampón.
  3. Creamos los sólidos interiores por este mismo método con una altura menor (5 mm) .
  4. Importamos en Freecad, convertimos a sólido y agregamos la base y las formas del paso 3.

Hay un método alternativo para el paso 3: importar directamente el SVG desde Freecad y extruir las formas. Teneis un par de excelentes excelente videotutoriales (este y este otro) sobre el proceso en la Obijuan Academy.

MATERIAL DE IMPRESIÓN

  • Para imprimir usaremos PLA, un termoplástico biodegradable procedente de recursos renovables tales como el maíz, raíces de tapioca, féculas y almidones varios y de la caña de azúcar Gracias a su consistencia más fluida a temperatura de extrusión (180-220ºC), es ideal para imprimir piezas con paredes finas. El PLA no es tóxico y puede estar en contacto con los alimentos en frío.
  • Limpiar los moldes con agua tibia y jabón después de utilizados. Nunca en el lavavajillas.
  • Para una mayor seguridad alimentaria es conveniente que la boquilla de la impresora sea de acero inoxidable (y no de latón por su contenido en plomo).

RECETA PARA MASA:

  • 125 gr. de mantequilla
  • 175 gr. de harina
  • 50 gr. de azúcar glass
  • 1 cucharada de leche

RECETA PARA MASA CON CHOCOLATE

  • 125 gr. de mantequilla
  • 160 gr de harina
  • 50 gr. de cacao en polvo.
  • 50 gr.de azucar glass
  • 3 cucharadas de leche

PREPARACIÓN:

Tamiza los 175 gramos de harina en un cuenco, añade el azúcar, el cacao en el caso de la masa con chocolate, y remueve. Agrega los 125 gramos de mantequilla troceada, trabaja la harina y la mantequilla juntas hasta que la mezcla parezca migas.Añade a la mezcla una cucharada de leche y mezcla con las manos hasta formar una bola de masa.

Deja enfriar la masa en la nevera unas horas envuelta en un film transparente para que sea más fácil de trabajar. Prepara una superficie lisa y espolvoréala harina. Estira la masa con un rodillo enharinado hasta obtener el grosor deseado y emplea el molde para cortarla. Coloca las galletas en la bandeja de horno sobre un papel encerado y hornea a 180º. Es importante haber precalentado el horno a esa temperatura.

A continuación os dejo algunas fotos del proceso. Que aproveche!

25_galletas.jpgASCII���...ASCII���...

proyectos/opencookies.txt · Última modificación: 2018/01/24 22:07 (editor externo)